vulnerability · openclaw
Plugin install commands could allow non-owner persistence
Plugin install commands could allow non-owner persistence. The official advisory identifies openclaw >= 2026.5.20, < 2026.6.9 as affected.
high severityconfirmed confidencepatchedNo known exploitation
Quick answer
What defenders need to know
- What is it?
- Plugin install commands could allow non-owner persistence. The official advisory identifies openclaw >= 2026.5.20, < 2026.6.9 as affected.
- Who is affected?
- openclaw >= 2026.5.20, < 2026.6.9
- What should defenders do?
- Upgrade openclaw to 2026.6.9 or later.
- Is a fix available?
- Yes. Upgrade to 2026.6.9.
01 / Response
What to do
- Upgrade openclaw to 2026.6.9 or later.
- Until upgraded, restrict the affected feature to trusted operators or disable it when it is not needed.
02 / Technical assessment
Evidence-backed analysis
OpenClaw's official security advisory assigns high severity with CVSS 8.8 and references CWE-269, CWE-862.
- Official advisory: Plugin install commands could allow non-owner persistence.
- Affected range: >= 2026.5.20, < 2026.6.9. First patched version: 2026.6.9.
03 / Timeline
Disclosure timeline
- Advisory published
OpenClaw published GHSA-7vrr-rp4x-4g76.
04 / Standards crosswalk
Standards crosswalk
FrameworkControl IDStatusEvidence
Control ID
LLM03risk alignmentStatusCandidate mapping
EvidenceNo supporting evidence published
Control ID
CWE-269weakness referenceStatusSupported
Control ID
CWE-862weakness referenceStatusSupported
05 / Primary sources
