vulnerability · openclaw
Discord guild actions could skip cross-provider requester authorization
Discord guild actions could skip cross-provider requester authorization. The official advisory identifies openclaw = 2026.6.6 as affected.
high severityconfirmed confidencepatchedNo known exploitation
Quick answer
What defenders need to know
- What is it?
- Discord guild actions could skip cross-provider requester authorization. The official advisory identifies openclaw = 2026.6.6 as affected.
- Who is affected?
- openclaw = 2026.6.6
- What should defenders do?
- Upgrade openclaw to 2026.6.9 or later.
- Is a fix available?
- Yes. Upgrade to 2026.6.9.
01 / Response
What to do
- Upgrade openclaw to 2026.6.9 or later.
- Until upgraded, restrict the affected feature to trusted operators or disable it when it is not needed.
02 / Technical assessment
Evidence-backed analysis
OpenClaw's official security advisory assigns high severity with CVSS 8.1 and references CWE-863.
- Official advisory: Discord guild actions could skip cross-provider requester authorization.
- Affected range: = 2026.6.6. First patched version: 2026.6.9.
03 / Timeline
Disclosure timeline
- Advisory published
OpenClaw published GHSA-3pmr-x9g8-m55r.
04 / Standards crosswalk
Standards crosswalk
FrameworkControl IDStatusEvidence
Control ID
CWE-863weakness referenceStatusSupported
05 / Primary sources
